logo separator

[mkgmap-dev] PrecompSeaGenerator - which geotools version?

From Gerd Petermann gpetermann_muenchen at hotmail.com on Sat Oct 27 11:20:07 BST 2018

Hi all,

I tried to find a geotools version which is compatible with Java11, but it seems this is not yet available.
I was however able to compile and execute the PrecompSeaGenerator with version 19.3.
The program prints a warning about an illegal attempt to close a file but seems to work after that.
I think that means we have to wait until the geotools devs do have a version that supports Java11
before we can update mkgmap to use that. The good thing is  that I did not have to change the sources,
so the change should be easy enough.


Von: mkgmap-dev <mkgmap-dev-bounces at lists.mkgmap.org.uk> im Auftrag von Thorsten Kukuk <kukuk at suse.de>
Gesendet: Samstag, 20. Oktober 2018 11:12
An: mkgmap-dev at lists.mkgmap.org.uk
Betreff: [mkgmap-dev] PrecompSeaGenerator - which geotools version?


I tried to update my build environment for OSM maps, but with
current mkgmap versions, I have some problems to get the SeaGenerator
working together with geotools.

Neither the old one I used until now with an older mkgmap version,
nor newer ones seem to work. With 19.3 I get the following error:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.geotools.resources.NIOUtilities (file:/usr/share/java/mkgmap-SeaGenerator/gt-metadata.jar) to method java.nio.DirectByteBuffer.cleaner()
WARNING: Please consider reporting this to the maintainers of org.geotools.resources.NIOUtilities
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Exception in thread "main" java.lang.NoClassDefFoundError: uk/me/parabola/splitter/OSMWriter
        at uk.me.parabola.mkgmap.sea.optional.PrecompSeaGenerator.runSeaGeneration(PrecompSeaGenerator.java:274)
        at uk.me.parabola.mkgmap.sea.optional.PrecompSeaGenerator.main(PrecompSeaGenerator.java:414)
Caused by: java.lang.ClassNotFoundException: uk.me.parabola.splitter.OSMWriter
        at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
        at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)

Any idea, what goes wrong?
What would be the correct splitter version and geotools version for


Thorsten Kukuk, Distinguished Engineer, Senior Architect SLES & MicroOS
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
GF: Felix Imendoerffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nuernberg)
mkgmap-dev mailing list
mkgmap-dev at lists.mkgmap.org.uk

More information about the mkgmap-dev mailing list