logo separator

Moving to Java version 7

27
Feb

This is just a notice that Java 7 will soon be required to run mkgmap. Version 7 was released in 2011 so I expect that most people already have it. If not, now is a good time to update in preparation.

Although it was over a year between the announcement that mkgmap would require Java 6 and it actually happening, this time there will not be such a gap!

Posted by steve on 27 Feb 2013

Latest commits

  • mkgmap-r4315 code cleanup: remove obsolete call of Collections.sort() after call of MdrUtils.sortList() which already does this..
    21 oct 2019
  • mkgmap-r4314 fix assertion error when option --make-poi-index is used.
    21 oct 2019
  • mkgmap-r4313 Improve code readability, no change in output expected.
    21 oct 2019
  • mkgmap-r4311 Ignore turn restrictions in ElementSaver when map is not routable to supress warning "ignoring unspecified/unsupported restriction" for type=restriction relations..
    21 oct 2019
  • mkgmap-r4310 Code cleanup, no change in output expected.
    21 oct 2019
See more...