logo separator

[mkgmap-dev] Maps no longer working after firmware upgrade?

From ael law_ence.dev at ntlworld.com on Fri Nov 16 15:20:05 GMT 2018

On Fri, Nov 16, 2018 at 01:10:33PM +0000, osm at pinns wrote:
> That is worrying !
> A currently in contact with Garmin about an address issue on the new
> gpsmap66 and it seems that addresses do no longer work on custom maps .
> On 16/11/2018 12:36, ael wrote:
> > I have just updated the firmware on my Etrex 20 to version 4.80.
> > 
> > The OSM map no longer works. Very worrying.

As a further check, I just downloaded a new map from http://garmin.openstreetmap.nl/
and tried that. Still not working.

If I try to navigate to a waypoint, it says that there is no routable
map available. But if if I try to visit a recent find, it finds a
route and mentions road names and the like. Not sure whether that is
coming out of some cache, or whether some aspect of the routing is still

The log and licence files from http://garmin.openstreetmap.nl/ do not
mention the version of mkgmap used. 
The map is at pleiades.uni-wuppertal.de/garmin/generic/10-11-2018/387c09aab3ba73bbc48e657f6290d60e for the next 4 days.

I selected Generic Routable version without a TYP file for simplicity.
The previous version which failed was "Generic Routable".

As before, my contour maps are working. I thought that they had been
generated with mkgmap, but I might be wrong.

As before, there is nothing displayed on the screen: only the contours,
waypoints, photo icons and so on. Just noything from the OSM enabled

Is there anything simple that I can do to help debug the problem?


More information about the mkgmap-dev mailing list