logo separator

[mkgmap-dev] Problems with boundaries and multipolygons

From Christoph Wagner freemaps.osm at googlemail.com on Fri Sep 18 12:51:10 BST 2009

Hello list,
I tried to build a garmin map with the boundaries from osm.
But with the newest mkgmap version there are some problems. In the
result some boundary ways are just missing.
With an older mkgmap version (I think older than the merge from the
multipolygon branch - I tried 1133) everything works fine.

I think the problem has to do with boundary relations that were in
germany tagged with:


but the members of these relations are often not closed ways and so I
think mkgmap produces wrong output.

Is it possible to deactivate the new handling of multipolygons on the
commandline until there is a fix?

Can somebody confirm this bug?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: OpenPGP digital signature
Url : http://lists.mkgmap.org.uk/pipermail/mkgmap-dev/attachments/20090918/5edbd767/attachment.bin 

More information about the mkgmap-dev mailing list