logo separator

[mkgmap-dev] Unable to search for Address - GPSMAP64s

From Gerd Petermann gpetermann_muenchen at hotmail.com on Thu Jul 23 07:38:26 BST 2020

Hi Andrew,

did you already try with the bounds.zip for planet?
Which address(es) do you search? Do you try a single place or various?
Some hints for a test plan:
For testing you should use a single file as input. If this works it is very likely that the complete map for Canada also works. You can use JOSM to download a small area around your place and try that or you can pick a single *.osm.pbf file produced by splitter.
Make sure that the addresses you are searching are well mapped in that input file.

If you test with the device make sure to rename all other *.img files that you installed before to e.g. *.img_old to avoid conflicts with family-ids or map-ids.
You may upload such a small gmapsupp.img to http://files.mkgmap.org.uk/ and I can check if it works on my Oregon.


Von: mkgmap-dev <mkgmap-dev-bounces at lists.mkgmap.org.uk> im Auftrag von Andrew Morris <drew101 at shaw.ca>
Gesendet: Mittwoch, 22. Juli 2020 23:21
An: Development list for mkgmap
Betreff: Re: [mkgmap-dev] Unable to search for Address - GPSMAP64s

So after some digging (and testing is still ongoing) I *think* I may
have figured out what is going on.  My use of the --country-abbr='CA'
instead of --country-abbr='CAN' may have been marking the addresses as
not Canadian and thus they weren't showing.  I've tried removing the
option completely hoping mkgmap would pick it up from the metadata, but
I don't think that worked.  I'm going to need to start doing a better
test plan.  Right now I'm kind of spinning my wheels and I'm on like
build 15.

Also there (at least in my opinion) is a bug in the firmware where if a
map is disabled it shouldn't use that map file for address information,
but it does.

I'll update as soon as I get some results.  Unfortunately this process
is slow (around 40 minutes each try) and I get distracted with other

Thank you for the suggestion on the -c template.args and geonames-file
options.  I'll give that a try on my next run.

On 07/20/20 06:35, Ticker Berkin wrote:
> Hi Andrew
> When you say you can't find cities, do you get a good list of nearby
> cities from the Find>Cities menu entry, and if you change this to
> search-by-name, can you find all that you'd expect (ie non-basemap
> ones).
> When using Find>Address, do you get a sensible Country or Region list
> in the initial selection field, and have selected something, do you get
>   a list of Cities in the City selection field, similarly for Street. On
> my device I need to clear the house number field to get from this point
> to the list of addresses that I can then select (because most of my
> addresses don't have housenumbers)
> I see references to postal_code in your bounds processing. I don't
> think you are going to get anything sensible to happen by default
> relating to Canadian postcodes; I think Garmin ZipCode handling only
> deals with numerics.
> Unrelated suggestions are:
>   Get the splitter to generate useful tile names with the
>   --geonames-file=... option.
>   Use these by having -c template.args rather than *.osm.pbf
>   Have the global --description at the end, after the above.
>   Beware of --split-name-index.
>   --link-pois-to-ways is a good option.
>   --code-page=1252 if you need French names with accents.
> See {mkgmap-rel}/examples/sample.cfg
> Ticker
> _______________________________________________
> mkgmap-dev mailing list
> mkgmap-dev at lists.mkgmap.org.uk
> http://www.mkgmap.org.uk/mailman/listinfo/mkgmap-dev
mkgmap-dev mailing list
mkgmap-dev at lists.mkgmap.org.uk

More information about the mkgmap-dev mailing list