logo separator

[mkgmap-dev] Having 2 mkgmap-generated files on one device at once

From Andy Townsend ajt1047 at gmail.com on Sun Mar 17 12:07:23 GMT 2019

Following on from the other question about setting the mapset name, the 
other problem is just having both files on the device at once.

Both .img files were created using mkgmap using the --gmapsupp parameter.

I have an existing "gmapsupp.img", and I've renamed the new test one 
that I am creating to "ajt2supp.img" and have also tried setting the 
description of it via '--description="AJT2D" '. Setting the description 
works, in that if that's the only mkgmap-generated map on the device 
that's the description I see from the maps available from "select map".

However, if I have both the old "gmapsupp.img" and the new 
"ajt2supp.img"on the device I only see "OSM Street Map" (the old 
description), not "AJT2D".

I'm guessing it's some other name or perhaps the argument order that's 
the problem.  I've tried other name settings such as --family-id=3 
--product-id=44 --mapname=63240002 --product-version=2  
--series-name="AJT2S" --family-name="AJT2F" --area-name="AJT2A", as well 
as --description="AJT2D", but to no avail.

Best Regards,


More information about the mkgmap-dev mailing list