logo separator

[mkgmap-dev] map boundary error

From Mike Baggaley mike at tvage.co.uk on Thu Feb 18 14:39:26 GMT 2021

Hi Gerd,

The data wasn't cached in BaseCamp (I have just done Ctrl+G twice to make

However, I had built using --gmapsupp rather than --gmapi, and copied the
gmapsupp.img file to an SD card. I have tried using --gmapi and the results
are correct there. I have also tried installing the registry settings and
that works OK as well, so it looks like a problem specific to gmapsupp.


-----Original Message-----
From: Gerd Petermann [mailto:gpetermann_muenchen at hotmail.com] 
Sent: 18 February 2021 07:57
To: Development list for mkgmap <mkgmap-dev at lists.mkgmap.org.uk>
Subject: Re: [mkgmap-dev] map boundary error

Hi Mike,

I cannot reproduce your result with the command
java -jar mkgmap.jar -gmapi test.osm.
I assume you look at cached data. Did you press Ctrl+G 2 times?


Von: mkgmap-dev <mkgmap-dev-bounces at lists.mkgmap.org.uk> im Auftrag von Mike
Baggaley <mike at tvage.co.uk>
Gesendet: Donnerstag, 18. Februar 2021 01:03
An: 'Development list for mkgmap'
Betreff: [mkgmap-dev] map boundary error

Hi all,

In creating a small test file I seem to have found an issue. The attached
OSM file has just 3 points and two ways form a right-angled triangle. In the
attached BaseCamp image, the blue line is the boundary of the map. Its
vertical lines contain the ways, but the horizontal lines do not. I can also
see that the road in the underlying base map enters into the blue rectangle,
suggesting that the blue line is not where the map boundary actually is. How
does this boundary line get created


More information about the mkgmap-dev mailing list