logo separator

[mkgmap-dev] Opening gmapsupp.img with Basecamp?

From Andy Allan gravitystorm at gmail.com on Thu Mar 31 12:23:47 BST 2011

On Sun, Mar 20, 2011 at 2:02 PM, Steve Ratcliffe <steve at parabola.me.uk> wrote:
> Hi
>> I've been experimenting with Garmin BaseCamp opening gmapsupp.img
>> files that I create. It works fine for some files (even getting the
>> .TYP styling correct) but not for others. After a few hours of testing
>> it seems that it'll open gmapsupp.img files created from 1-20 .osm
>> files but not 30+ .osm files. I'm not certain yet if it's the exact
>> number of files, or the combined size that triggers the failure.
> Is the size of the resulting gmapsupp.img around 128M when it goes wrong?
> If so it could be the 'filesystem' parameters in the header, which are
> set to allow a size of 128M.  This is ignored by devices so isn't
> usually a problem.

Sorry for the delay. That's exactly the problem, it works for maps up
to 128M but not higher than that.

I had a little explore in the source code and found the tantalising
"gives 128M will try more later" comment, and naively tried a larger
number of cylinders. Tried 0x200 but that didn't work. Reading the
code below that bit I realise now it might not be so easy :-)

I'm happy to do some more experimentation / testing patches etc if you
can give me some things to try.


More information about the mkgmap-dev mailing list