logo separator

[mkgmap-dev] please test r3942

From Gerd Petermann GPetermann_muenchen at hotmail.com on Mon May 15 07:57:26 BST 2017

Hi Nev,

thanks for the hint, just tried it. The downgrade works but it doesn't solve the problem, so I am using 5.00 again
(and restoring my settings ... )

Von: mkgmap-dev <mkgmap-dev-bounces at lists.mkgmap.org.uk> im Auftrag von nwastra <nwastra at gmail.com>
Gesendet: Montag, 15. Mai 2017 08:35:41
An: Development list for mkgmap
Betreff: Re: [mkgmap-dev] please test r3942

Hi Gerd
There is an archive of Garmin updates here http://gawisp.com/perry/ and for Oregon here http://gawisp.com/perry/oregon/
and this may be the 4.6 update gawisp.com/perry/oregon/Oregon6x0_WebUpdater__460.gcd<http://gawisp.com/perry/oregon/Oregon6x0_WebUpdater__460.gcd>
I have not used these before so I am unsure if you can revert to the older state using these?


On 15 May 2017, at 3:52 PM, Gerd Petermann <gpetermann_muenchen at hotmail.com<mailto:gpetermann_muenchen at hotmail.com>> wrote:

Hi all,

It seems that r3942 produces maps which work quite well with MapSource and Basecamp.
I can find roads with names like Æblegården or "Außer Ort".
I find POI in the expected category.

Anyhow, I see different results on my devices.
It seems that the Oregon 600 with firmware 5.00 doesn't "understand" the GARMIN SRT file.
Road names containing characters which appear in the "expand" section cause trouble.
For cp-1252 (--latin1) these are
expand … to  . . .
expand ¼ to  1 / 4
expand ½ to  1 / 2
expand ¾ to  3 / 4
expand æ to  a e
expand Æ to  A E
expand œ to  o e
expand Πto  O E
expand ß to  s s
expand ™ to  T M
I am pretty sure now that this is a bug in the Oregon firmware.
It would be interesting to know if firmware 4.60 worked. According to this page
there was a change described "Improved address search" with 4.80. Unfortunately I was not able to
download any previous version. Any hints?

The Nüvi2447 seems to work fine with maps created with --latin1 (also with --lower-case)
but says that --unicode  maps are broken. This also happens when I use MapSource to
install the map on the device. The installed map "GARMIN  CN Europe NTU 2018.1" is a unicode map
and works fine.

So, if you create maps which contain road names containing special characters,
please try how maps created with r3942 work on your device(s).
I've uploaded a copy of the version here:

These are the test cases that don't work on my Oregon:
Map around Copenhagen:
- Search for all roads in Denmark starting with Æ (switch to Danish keyboard to be able to type that character)
or Ae doesn't find any road, it should find many.
- Search for other special characters like Ø works fine.
- Search for all roads in city "Albertslund Kommune" lists
Æblets Kvt
Alberts Have
Alberts Vænge
When I search for roads starting with A in Albertslund Kommune it lists only  Abildgården
Similar results with other searches, the device seems to stop reading the data when the first name with Æ is hit.
When I search for AL (so that it doesn't read the Æ name) it lists the above roads.
Don't know if I should contact Garmin ?

mkgmap-dev mailing list
mkgmap-dev at lists.mkgmap.org.uk

More information about the mkgmap-dev mailing list