logo separator

[mkgmap-dev] Problems with routing on Etrek 20 with latest firmware

From ael law_ence.dev at ntlworld.com on Thu Jul 28 13:55:58 BST 2016

I hope this is an appropriate post for this list.

Since I updated my Garmin Etrex 20 to the latest firmware (4.30
I have had problems with routing with OSM maps generated with

So far, I have only tried standard maps from
http://garmin.openstreetmap.nl/ and http://extract.bbbike.org/.  (My
previous quick attempts to run mkgmap directly failed after I was unable
to find documents that explained the process sufficiently clearly,
although I may now need to try again after this problem.)

Trying various routes that had always worked with previous versions of
the firmware, I get a variety of symptoms including:

1) Apparent deadlocks (requiring batteries to be removed to achieve

2) "Route calculation error";

3) "The route does not match the available maps. Cannot follow the roads
precisely. Do you want to recalculate the the route?" Choosing [Yes]
gives "Route calculation error. Maps do not have routable roads in this

A quick google search only showed one similar very brief report of
similar problems (although not with mgkmap/OSM so far as I could tell)
after firmware 4.30 was installed.

Is this a known problem? Garmin certainly changed more than they
documented on this firmware revision: for example version 4.30 could not read
Waypoint files written by previous versions.

Thanks for any help on this. If I can help with diagnosis, please let
me know.


More information about the mkgmap-dev mailing list