logo separator

[mkgmap-dev] [PATCH v1] garmin_area() style function

From Henning Scholland osm at aighes.de on Thu Jul 11 22:14:44 BST 2013

Hi WanMil,
great work!

Am 11.07.2013 23:04, schrieb WanMil:
> The patch adds a new style function called garmin_area().
> garmin_area() returns the size of an area in garmin-units ^2. It works 
> for polygons only. Unclosed ways return 0.
> Please test it and let me know:
> * Do you have a better name?
What about polygon_size() or area_size() ?

> * What to do with multipolygons? Should garmin_area() return the 
> multipolygon size for all splitted parts of the mp?
For me this would be the prefered solution, because the user have not to 
care about polygon/multipolygon.


More information about the mkgmap-dev mailing list