logo separator

[mkgmap-dev] gpx track files do not work on routable maps

From Eric Fernandez zeb at zebulon.org.uk on Mon Mar 5 16:31:31 GMT 2012


> Thanks. On my device they are just tracks and not routes. I've seen
> Felix's message and your reply, so perhaps the Edge is just different in
> that way.
> The track looked fine and was the same as the website map at first glance.

Many thanks Steve for looking into it. Indeed, the Edge can accept
both GPX track and GPX route formats (as described in
They are almost the same, but GPX track offers better navigation on
the Edge. As you say, this could be a peculiarity with the the Edge,
although the Garmin maps work fine, suggesting there may be something
missing in the routing format.

The funny thing is that I can display the track correctly on the map
(as a dotted line), showing that the Edge correctly reads the file
itself. But the routing fails when using an OSM generated with mkgmap.

> The only way to get more clues is to find the shortest track that
> doesn't work and a very similar one that does and see if there is
> anything strange about the difference. And you might have to
> find lots of working/not working pairs to see if there is anything
> common between the differences.

I have started to do that, but have a lot of trouble in finding a GPX
that works. "Where to" navigation does work, but there seem to be some
issue in recording the route. I also tried several firmware versions
with the same result. It is a pity we do not know how the edge works
internally to calculate routes!

I'll try to find a case study with working and not working tracks then.

Thank you,

More information about the mkgmap-dev mailing list