logo separator

[mkgmap-dev] Serious Bug - Mkgmap creating map that puts news GPS (confirmed etrex 30, Oregon 550) into bootloop

From Felix Hartmann extremecarver at gmail.com on Fri Feb 24 09:24:23 GMT 2012

Bang, I think that's it. I now managed to sent a map including the bay 
of biscay (one tile), and looked if the other really small tiles 
included cities/islands. Found one that didn't, left it out and the GPS 

IMHO (I'll try to simply include a city POI into the tiles of biscay) - 
we would need to make sure, that each tile has a city or island 
(0x650c)! Maybe that could be related to how the search function is 
organised? Loading maps the GPS usually tries to set up the POI index 
internally. Maybe that's why it crashes. Too few/no cities or no POI at 
all, and bang.

My next try will be to simply include city POIs with gpsmapedit into 
each tile of the gulf of biscay, and recompile...

On 24.02.2012 10:04, Felix Hartmann wrote:
> I just tried - I left out the two main tiles of the Bay of Biscay, and 
> it booted (and to confirm I created the gmapsupp.img with both mkgmap 
> with and without address search, and also Mapsource). Leaving out 
> either of the two tiles,
> So leaves us to wonder, why is it not booting with them.
> The main thing inside those two tiles, is the ferry line, go straight 
> across. Is it possible, that we have to use shorter staight lines? 
> Where could I patch mkgmap to split up straight lines say 5x as often?
> The other thing could be - that there must be at least one city POI in 
> each tile (or at least any?? POI in each tile) - as both tiles don't 
> have any city. And only one of the two tiles has a POI at all.
> I'll also try what happens if I create the map with default 
> style-file. But I think it will crash the gps device too.
> BTW -- I split france from geofabrik with max-nodes=1200000 and 
> maxnodes=1300000 and both results in the same problem.
> Or do we have to make sure, that mkgmap never creates such empty tiles?
> On 23.02.2012 23:44, Minko wrote:
>> On a Dakota 20 I can confirm this behaviour.
>> If I leave only tile 63910019 out of it, it still won't boot up.
>> I did not try it without tile 63910035.
>> With a smaller mapset with 63910019 and 63910035 and a few others, no 
>> problems.
>> Also tried to leave out two other tiles in the north, but then it 
>> still won't boot.
>> _______________________________________________
>> mkgmap-dev mailing list
>> mkgmap-dev at lists.mkgmap.org.uk
>> http://www.mkgmap.org.uk/mailman/listinfo/mkgmap-dev

More information about the mkgmap-dev mailing list