logo separator

[mkgmap-dev] How to use the index branch

From Felix Hartmann extremecarver at gmail.com on Fri Jan 7 22:25:35 GMT 2011

On 07.01.2011 22:52, WanMil wrote:
> I tried to use the index branch but I don't know the little tricks to
> get address search working in MapSource (and of course not on my
> Garmin). Can someone please summarize (Steve, Felix) what I have to do
> use it at least in MapSource? How do you test the index branch?
> What I've tried:
> * Create a map from the index branch with compiling an nsis map installer
> * Run the mapinstaller exe
> * Start MapSource
> =>  The map is installed but Search =>  Search city is disabled.
> WanMil
> _______________________________________________
> mkgmap-dev mailing list
> mkgmap-dev at lists.mkgmap.org.uk
> http://www.mkgmap.org.uk/mailman/listinfo/mkgmap-dev
Check the registry - you need to have the following entries (wow6432node 
is for x64 systems only):

reg QUERY 
HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366 2>NUL >NUL
if %errorlevel% EQU 0 reg DELETE 
HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366 /f
reg ADD HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366 
/v ID /t REG_BINARY /d DE18 /f 2>NUL >NUL
reg ADD HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366 
/v TYP /t REG_SZ /d "D:\Garmin\0mtb\mtbaustria1\6366trad.TYP" /f 2>NUL >NUL
*reg ADD HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366 
/v MDR /t REG_SZ /d "D:\Garmin\0mtb\mtbaustria1\mapset6366_mdr.img" /f 
reg ADD HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366 
/v IDX /t REG_SZ /d "D:\Garmin\0mtb\mtbaustria1\mapset6366.mdx" /f 2>NUL 
 >NUL *
reg ADD 
HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366\1 /v Loc 
/t REG_SZ /d "D:\Garmin\0mtb\mtbaustria1\\" /f 2>NUL >NUL
reg ADD 
HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366\1 /v 
Bmap /t REG_SZ /d "D:\Garmin\0mtb\mtbaustria1\mapset6366.img" /f 2>NUL >NUL
reg ADD 
HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366\1 /v Tdb 
/t REG_SZ /d "D:\Garmin\0mtb\mtbaustria1\mapset6366.tdb" /f 2>NUL >NUL
reg QUERY 
HKLM\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\FAMILY_6366\1 /v Tdb 

Important bits are mdx and mdr_img
if they are missing, then find places is greyed out. I don't know if the 
nsi is including them by default, as I have a script to write the nsi 
seperately (to include more options like refinding and older 
installation path, or checking that Mapsource is closed when installing 
- else installation fails on the address search as the entries get 
blocked while Mapsource/Basecamp is running).

Crazy thing is, if for one single map the address search is wrongly 
registered, other maps might fail to provide working address search in 
Mapsource (at least for 6.13 branch, I think 6.16 got it fixed).

On trunk currently mdx files are broken since the cleanup. Will check 
out --index branch now.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.mkgmap.org.uk/pipermail/mkgmap-dev/attachments/20110107/9fee143a/attachment.html 

More information about the mkgmap-dev mailing list