logo separator

[mkgmap-dev] basic search

From Johann Gail johann.gail at gmx.de on Sat Oct 2 12:04:51 BST 2010

> I can confirm this: after transferring maps to my eTrex with either Mapsource on Windows/Wine or MapInstall on the Mac, address search works -- at least with the known limitations of mkgmap's index generation.
> I have not recently attempted to copy a generated gmapsupp.img file to my device, but I recall that the address index did not work in this case. I assume that this has not changed.
I have just tried to generate a mapset with mkgmap. I set the options 
--index --route beside others and get the *.img files, a tdb file, a mdx 
file and a *_mdr.img which contains the index. So far so good.

But if I registry this mapset with mapsource, then I only can see the 
map. Searching for adresses does not work, because the menu item is 
grayed out. Is this a expected behaviour or did I something wrong?

I have not tried to transfer the maps to my etrex, because the first 
step did not work. Should I give it a try?


More information about the mkgmap-dev mailing list