logo separator

[mkgmap-dev] Really Serious bug when not using --route

From Felix Hartmann extremecarver at googlemail.com on Mon May 31 16:47:49 BST 2010

On 31.05.2010 15:56, Johann Gail wrote:
>>> A possible way to find the flag:
>>> With MapSource (at least with 6.13) it is possible to include or exclude
>>> the routing data when transferring to the device. If you transfer the
>>> same data twice, one time with, the ther time without the routing data,
>> A great idea!
>> Unfortunately my results are that all the sub-files are unaltered
>> and bit for bit identical in the two cases.
>> All the changes in the header appear to be consistent with the changes
>> required for the fact that the files are different sizes and one
>> does not contain NOD.
> Ok, so there IS NO NOD flag. I really haven't expected this result, but
> seems the case here.
>> I've had no luck with finding anything.  I've tried unsetting all the
>> flags that we don't know the meaning of, so it seems that it might
>> not be a simple flag that we always set but shouldn't.
> Two things come to my mind.
> 1. Could it be a matter of draw priority? Maybe the routable map needs a
> higher drawing priority to be in front? In the other case routing will
> be tried on the non-routable map and fail.
No I played around with that already. Has no influence.
> 2. Could it have to do something with the detailed map/basemap flag? To
> write a patch for this bit should not be that complicated, but iirc
> setting this bit breaks routing.
Well you're provided patch did not break routing for me. I will try out 
later if it solves the problem when --route is not given, though not 
having noticed any differences when using the patch for normal 
autoroutable maps, I doubt it solves the problem.
> Regards,
> Johann
> _______________________________________________
> mkgmap-dev mailing list
> mkgmap-dev at lists.mkgmap.org.uk
> http://www.mkgmap.org.uk/mailman/listinfo/mkgmap-dev

More information about the mkgmap-dev mailing list